===== fucking bsd notes ===== Hopefully some of this stuff will help me get over the hump to migrating away from Linux to BSD ==== Different BSDs ==== * Dragonfly is x64 only * GhostBSD is 64-bit only, requires at least 4GB of memory, and only MATE DE is supported ==== FreeBSD ==== === Using Packages === Install the package manager with # pkg Install packages with # pkg install === unqualified host name === If you have a delay at boot because of an unqualified host name # hostname # nano /etc/hosts Then add your hostname to the 127.0.0.1 entry === reduce boot delay === This is the main timer at boot (10 seconds by default) # nano /boot/loader.conf autoboot_delay="3" === mount samba share === # mount_smbfs //user@server/shared /home/user/shared === services === List running services # service -e Add a service to /etc/rc.conf # sudo sysrc nginx_enable=YES === user stuff === Change shell $ chsh -s bash Does this work to install a desktop environment? # pkg install xorg openbox $ echo "exec openbox-session" > ~/.xinitrc